Stuck on Starting Lua forever

I have been playing on the HWRP server for about 2 weeks now. It is the only server I play on for Gmod.
I play on 64 bit version. After a few days, when I try to load into the server, the following problem happens. My bar at the bottom right of my screen is 100% and it says: Starting Lua. But nothing happens..
I am forever on the loading screen and I never join the server. I have reset my Gmod to factory settings and that fixed it for me. But all my key-binds are reset which is a massive pain..
Right now I can play for one session after reinstalling gmod and when I try to log back in later to the server I have once again the same problem....
[Image: 92a2ca0b8a4ec9474a0b1e1a953262a9.svg]
I tried googling it but so far the factory reset is the only option I found.. Do you know of a fix for this? much appreciated in advance for your time
[Image: 1904291ab1aa5d14b2adaaff23a578dd.svg]

Try to delete the folders "addons" and "download" with your GMod closed.

The path should be: (C:) > Programs (x86) > Steam > steamapps > common > GarrysMod > garrysmod

If these don't work, try the "maps" folder. It should be located on the same path.

Sailor Etlenor Dragon Pizza Rivers Kronior

[Image: cpsailorhat.png?width=1164&height=676]

~ Best and Former Ravenclaw House President ~ 
~ July 2016 ~
~ A Dragon since April 14, 2018 ~

Expand Signature

Just learn GLua and ez here this video will get you started

Trial Helper 26th Of July 2020
Full Helper 9th of August 2020
Resigned 1st of October 2020
Forum Master
[Image: gladys.png]
Expand Signature

Thanks for the help!

So far after I set it all back to factory settings its all working as intended so far. (before the help i got in here)

if I do get stuck on the loading again I will try these options and report back in here if it workes. 
Thanks for the replies!  harrylove

Issue resolved,
Thread Locked

~Joined July, 2016 ~

Edwin Tossil-Dragon / CT 2711 Tossil
~ Former HW Gamemaker ~
~ Former HW Moderator ~
~ Forum Admin ~
Expand Signature

Forum Jump:

Request Thread Lock

Users browsing this thread:
1 Guest(s)